I have a Aprilaire 5000 air cleaner, which I have purchase and had installed under my air exchanger with a heat pump system.

Wednesday, November 17, 2010 by Aprilaire Team
Consumer question:

I have a Aprilaire 5000 air cleaner, which I have purchase and had installed under my air exchanger with a heat pump system. I have installed a new Aprilaire media about a month ago and then cleaned the screen and the ion wires and then reinstalled back in the unit. When the unit runs the blue light on the door comes on for about a minute and then goes off and then comes back on after about a mintue and it continues to do this while the unit is running. I have cleaned the unit completely, but the light will stay on the hold time the unit runs. Can you tell what else I need to do.


Aprilaires' response:

Thanks for contacting us about your 5000 Air Cleaner. I have a couple of steps to try and figure out what is wrong with your unit.

1-Take door off and plug in at another outlet somewhere ( hallway, bedroom, etc.)
  -----If light is on, then the door is fine.
  -----If light stays off, then door is bad and needs to be replaced.

2-If door light comes on in another outlet try taking the large metal screen off of the unit (Control Electrode) and put everything back together minus the metal screen. If the light stays on then the screen (Control Electode) will needs to be replaced.

Anything else will be covered in the FAQ's troubleshooting section. Please review that attachment for anything other questions and feel free to ask me any questions that come up.

Comments for I have a Aprilaire 5000 air cleaner, which I have purchase and had installed under my air exchanger with a heat pump system.

Wednesday, December 26, 2012 by Tony:
Thank you so much . It helped solve my problem . Once I took screen( Control Electrode) my light stayed on . I will buy new screen and replace it

Leave a comment





Captcha