Sand/Silt in my water, is that effecting my Aprilaire steam humidifier?

Consumer question:
 
I had installed about 4-5 months ago. I get a build up a yellow/brown sand / silt in the bottom which seems to clog the drain and causes the canister to leak from the top. I live in the Denver area (Lone Tree). I saw a post on another web site with a similar issue. Do you have a recommendation to fix? Maybe a sand/silt trap/filter upline?
 
 
Aprilaires' response:
 
Thank you for contacting us with regards to your model 800 Residential Steam Humidifier. What you're finding is the sediments in the water that are left behind as the water boils away. The exact nature of these sediments can vary by region. We don't have any specific recommendations for filters, but if you do choose to have on installed, do not use one that de-ionizes or de-mineralizes the water, such as Reverse Osmosis. Some amount of dissolved minerals are required for our unit to produce steam. The 800 uses the minerals in the water to pass current between two electrodes, and the fewer minerals in the water, the longer it will take to reach boiling. We would recommend that you consult your installer for recommendations on filters for sand, though.

One thought on “Sand/Silt in my water, is that effecting my Aprilaire steam humidifier?

  1. Marion

    Hi there very cool web site!! Man .. Beautiful .. Amazing ..
    I’ll bookmark your website and take the feeds also?
    I’m glad to find a lot of useful info right here in the publish, we want develop extra techniques in this regard, thanks for sharing.
    . . . . .

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>