The filter on my Aprilaire model 600 humidifier doesn’t seem to be filling with water.

Consumer question:

The filter on my Aprilaire model 600 humidifier doesn’t seem to be filling with water. Nothing has changed since the last season and the setting is at 5.

Aprilaires’ response:

If it is set at 5 that is equivalent to about 35% humidity. So if the current humidity level is higher than that it would not be running. An easy way to tell is to turn the unit to test reset (turn it past 7 and the humidifier on light should begin to blink with our 58-60 control) This should turn the humidifer on and it will run for approximately one minute. If this happens the unit is functioning normally and then when you turn it back to 5 it should come on , if the HVAC is running and the humidity falls below 35%.

2 thoughts on “The filter on my Aprilaire model 600 humidifier doesn’t seem to be filling with water.

  1. James BRENNAN

    I have an aprilaire humidifier model 600. None of the lights on the control panel are light
    When I go to reset the green on light blinks. humidifier does not come on.All lights remain unlite. I checked the 24v power supply at the transformer and its ok. jumped the soliniod with 24v and it works fine.
    Please assist me before I buy a new control panel, whick at this time I assume is bad.

    Thank you
    Jim BRENNAN

    Reply
    1. aprilaireadmin

      Hello Jim,

      Thank you for contacting us regarding your humidifier. What model control do you have for your humidifier? When you are testing the unit is the furnace on?

      Please let us know and we can help more!

      Reply

Leave a Reply

Your email address will not be published. Required fields are marked *