My Aprilaire Model 8570 thermostat is no longer displaying the outdoor temp, any ideas?

Consumer question:

I recently noticed that the outside temperature no longer displays on my Aprilaire 8570 thermostat. I have the outside monitor installed. It used to display. I just thought of this, but could it be that it is covered up by mulch or something which is preventing it from registering. If tha is not the case, could there be another reason? I am sure in the winter, snow could have the same affect unless it was placed some where that will not get covered by snow. Please let me know your thoughts. Thanks!

Aprilaires’ response:

Thank you for contacting us with regards to your model 8570 Thermostat. The outdoor temperature sensor would not necessarily fail if it were covered, but only if the wires were cut or disconnected. In order to register the correct temperature, it should be placed outside, on a non-south facing of the home, away from any exhaust vents and above any potential snow line. Failure to do so could result in an incorrect temperature reading. If your thermostat has lost connection to the temperature sensor entirely, the failure could be with the sensor, the wire or the thermostat. Try removing the faceplate of the thermostat, give it 10-15 seconds to power down and then plug it back in. If the outdoor temperature comes back, it may have simply lost connection at some point. If it does not come back, you may need to have your installer or another HVAC contractor test the sensor. It should be tested at the wires inside the thermostat as well as at its installation position outside. If the sensor has failed, it should be replaced with part #8052. If the wire has failed, it might be possible to repair the wire, or else it should be replaced.
Please let us know if you have any further questions.

4 thoughts on “My Aprilaire Model 8570 thermostat is no longer displaying the outdoor temp, any ideas?

  1. Mike Rutkovsky

    I have a 8570 thermostat used with a Trane heat pump/ac and would like to know why the 8570 reads 3-4 degrees higher than the real indoor temp? I have used three different thermometers to confirm the inaccurate read. Could this be adjusted? Thank you

    Reply
  2. Will

    Thank you for your email regarding the Aprilaire model 8570.
    If the Aprilaire Model 8570 thermostat is no longer displaying an outdoor temp it is because one of the sensor wires is open. If you have a 3-4 degrees difference it could be fixed by re-striping wires and replace any wire nuts, if that don’t fix it make sure there is not high voltage wires within 2’ of all sensor wires.

    Reply
  3. f olmtak

    my 8570 thermostat is in ‘permanent hold’ s result of a interruption of current.
    how can I reset to get rid of the ‘permanet’ hold or, if nenessary, how to do a complete reset.
    Thanks !

    Reply
    1. aprilaireadmin

      Thank you for contacting us with regards to your model 8570 Thermostat. To remove the “PERMANENT HOLD” press the far left button two times and the 8570 will resume back to your scheduled set points. This thermostat does not have a reset button.

      Please let us know if you have any further questions.If you have any further questions regarding this or any of our products, please feel free to contact our customer service department at your earliest convenience.

      Reply

Leave a Reply

Your email address will not be published. Required fields are marked *